summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..a2b6a1c
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,14 @@
+cmake_minimum_required (VERSION 3.13.4)
+project (VOLGIT)
+if( NOT CMAKE_BUILD_TYPE)
+ set(CMAKE_BUILD_TYPE "Debug")
+endif( NOT CMAKE_BUILD_TYPE)
+include_directories(${CMAKE_SOURCE_DIR})
+set(SOURCES
+ git_part.c
+ volgit.c
+ )
+
+
+add_executable(volgit ${SOURCES})
+target_link_libraries(volgit git2)