summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGalin Simeonov <gts@volconst.com>2021-09-25 11:43:15 +0300
committerGalin Simeonov <gts@volconst.com>2021-09-25 11:43:15 +0300
commit9868bd4ae045aadeb5cd9af6a13231462948077e (patch)
tree14f48c77bf0a0a93ff311079502f05bcc3593324 /CMakeLists.txt
parent4e7e1184d5b8b1d067134e7c7459f1c610ac55e6 (diff)
downloadvolgit-9868bd4ae045aadeb5cd9af6a13231462948077e.tar.gz
separating git stuff into a different file
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..a2b6a1c
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,14 @@
+cmake_minimum_required (VERSION 3.13.4)
+project (VOLGIT)
+if( NOT CMAKE_BUILD_TYPE)
+ set(CMAKE_BUILD_TYPE "Debug")
+endif( NOT CMAKE_BUILD_TYPE)
+include_directories(${CMAKE_SOURCE_DIR})
+set(SOURCES
+ git_part.c
+ volgit.c
+ )
+
+
+add_executable(volgit ${SOURCES})
+target_link_libraries(volgit git2)